Tutorial 1: Introduction to the Android Development Environment

Admin Details:

Individual Assignment: You must complete this tutorial on your own.
Due date: 9/5/2014 by 8 pm, late work is not accepted

Submission: t1.zip a zip file of your Eclipse project.

Submit files via Canvas

Value: Completion of this tutorial is worth 25 points, about 2.5% of your final grade.
Introduction

In this tutorial, you will setup your Android development environment and go through the Hello World tutorial
on the Android Developer website at http://developer.android.com/training/basics/firstapp/index.html.

You will also learn about using the Eclipse debugger and logging errors and other information in a running
Android application.

You may complete this on your own machines or the computers in the CS department Microlab. Eclipse and the
Android development environment is already set up on the Microlab Windows machines and the public Linux
machines. Be careful when using the Linux system. If you create an AVD (Android Virtual Device, an emulator to
test Android apps) it can eat up your entire hard disk quota on the CS Linux system. Set the Ram and internal
memory very low for your AVD.

Setup Your Environment (Skip this part if using the department's machines.)

The best way to develop applications for Android is using the Eclipse IDE and the Android plug-in for Eclipse
called Android Development Tools (ADT). You can test your applications by running them on an Android Virtual
Device (AVD), an Android emulator.

To setup your environment, follow each of the steps below in order. Installation instructions are available here:
http://developer.android.com/sdk/index.html

1. Download and install JDK 7
http://www.oracle.com/technetwork/java/javase/downloads/index.html

2. If you don't have Eclipse or want to try the all in one Android - Eclipse download visit
http://developer.android.com/sdk/index.html and download the SDK with the ADT Bundle for your
system. This includes Eclipse, the Android Development Tools (ADT plugin), the Android SDK, and other
tools. This is designed to be an all in one install, although | have not used it.

3. If you already have an Eclipse IDE the same page has instructions under "USE AN EXISTING IDE". This
entails downloading the SDK Tools and installing the ADT yourself.

("A new Android development environment called Android Studio, based on IntelliJ IDEA is available as
an early access preview," but | have not worked out all the technical issues with Android Studio for the
lab and for turning in projects. | require you to use Eclipse for the CS371m tutorials. You may use
Android Studio on your app projects later in the semester.)
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Working on the Departmental Machines
The Android development environment is installed on the CS Department Windows and Linux machines.

Using the Windows machines is straightforward. Just run Eclipse and created AVDs. Please note the AVDs get
wiped each time you log out.

If you want to work on the Linux machines you must complete some set up. The AVDs take up a lot of memory
and will quickly consume your 2GB departmental disk quota.

There is a projects folder for the class you can use to store your AVDs. This will not eat into your disk quota.
The name of the projects folder is cs371m-scottm

To set up your .android directory in the projects folder to store your emulators:

make a directory in the /projects directory

something like
mkdir /projects/cs371lm.scottm/<user name>

Then you willwanta .android directory
mkdir /projects/cs371lm.scottm/<user name>/.android

Then go to your home directory
cd

Then make the symlink
In -s /projects/cs371lm.scottm/<user name>/.android

This pre-supposes you do not already have a /u/<user_name>/.android
directory.

If you DO, you can
mv .android /projects/cs371lm.scottm/<user name>

instead of doing the second mkdir above, and then make the symlink.

We have 20GB to start. If you have space issues while using the projects directory please let me know.

Building Your First App Tutorial

Complete the “Building Your First App” tutorial at
http://developer.android.com/training/basics/firstapp/index.html which takes you through creating an Android
Virtual Device (AVD), creating an Android project, creating two Activities that interact with each other, adding
some simple GUI components, editing the layout xml file, using the visual GUI editor, starting another Activity
via an Intent, and running the application in the emulator. Complete all four sections of the tutorial: Creating an
Android Project, Running Your Application, Building a Simple User Interface, and Starting Another Activity.
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Use a min API level of 14 (version Android 4.0, Ice Cream Sandwich) and a target API level of 17 (Android 4.2,
JellyBean).

If you are working on the Microlab Windows machines or public Linux machines, you can create your own AVDs
via the AVD manager.

If you are working on the CS Linux machines, please note the following: Eclipse is installed on the machines and
you can start in by running eclipse on the command line. When you open it for the first time, a box will
come up asking where to find the Android stuff. Hit the radio button by "Use existing SDKs" and enter
/lusr/opt/android-sdk-linux-r23_0_2 in the box.

Here is a screenshot of an AVD | created on the lab machines. Note the choices | made for the emulator's
properties. This configuration led to an emulator that started up fairly quickly:

™ Create new Android Virtual Device (AVD)

AVD Name: Simple_AvD

Device: 4" WVGA (Nexus S5) (480 = 800: hdpi) v
Target: Android 4.2.2 - APl Level 17 v
CPU/ABI: ARM (armeabi-v7a) v
Keyboard: [ Hardware keyboard present

skin: WXGATZ20 v

Front Camera: Mone v

Back Camera: Emulated v
Memory Options: | RAM: | 512 VM Heap: | 32
Internal Storage: 200 MiB
SD Card: @® Size: MiB |+

File: Browse
Emulation Options: Snapshot [ Use Host GPU

erride the e A esame name
Cancel | OK

When you run an Android application, Eclipse will first start an emulator if one isn’t already running. If you have
multiple AVD configurations, it’s usually a good idea to first start your emulator of choice so you can control
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which emulator you want to use. It may take a few minutes for your emulator to appear because of a lengthy
initialization period... you’ll have to be patient. (http://stackoverflow.com/questions/1554099/slow-android-

emulator) You can watch the status of the emulator from Eclipse’s Console window. It will look something like
the lines displayed below which show how the .apk file is first installed and then launched:

[2011-10-22 14:22:34 - HelloAndroid] ---------------—----"-"---~~—~—----

[2011-10-22 14:22:34 - HelloAndroid] Android Launch!

[2011-10-22 14:22:34 - HelloAndroid] adb is running normally.

[2011-10-22 14:22:34 - HelloAndroid] Performing com.example.HelloAndroidActivity activity launch
[2011-10-22 14:22:34 - HelloAndroid] Automatic Target Mode: using existing emulator 'emulator-5554'
running compatible AVD 'MyDevice'

[2011-10-22 14:22:34 - HelloAndroid] Uploading HelloAndroid.apk onto device 'emulator-5554'
[2011-10-22 14:22:34 - HelloAndroid] Installing HelloAndroid.apk...

[2011-10-22 14:22:38 - HelloAndroid] Success!

[2011-10-22 14:22:38 - HelloAndroid] Starting activity com.example.HelloAndroidActivity on device
emulator-5554

[2011-10-22 14:22:40 - HelloAndroid] ActivityManager: Starting: Intent {
act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER]

cmp=com.example/.HelloAndroidActivity }
o sssaMyDevice TR T T et
5 Ml & 7:28em

You can also open up the LogCat to see that the HelloAndrold
emulator startup process is making progress. In
Eclipse go to Window -> Show View -> Other ->

Android -> LogCat

Hello World, HelloAndroidActivity!

Once the application is started, you will see it running
like the figure on the right. Note that this is the
default Android 2.3 AVD skin. If you use a different
version of Android, your emulator will look somewhat
different.

You can use the emulator as you would a real
Android device by using your mouse to click on the
screen and using your keyboard to type.

When you make changes to your program, DO NOT L
CLOSE THE EMULATOR Just edit your program, save it (which makes Eclipse re-build it), and re-run your new
program (Ctrl-F11); the emulator will replace the previous program with the new one and execute it (you’ll have
to be patient... it can take up to a minute to reload).

The Android Package

The .apk file, the Android Package, is the application file that was installed and executed on the emulator. The
.apk file is produced by Eclipse in a number of steps as illustrated in the figure below.
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javac

Java code |—— ¥ Byte code
- dx .
Jjava .class Dalvik exe
classes.dex aapt
Byte code <xml> L
Other .class files AndroidManifest.xml .apk
I <str>

Resources

1. The Java source code is compiled into Java bytecode (.class files) as is traditionally done in Java
programming.

2. The dx tool converts the Java bytecode into Android bytecode (.dex files), a compact format that can be
executed by a Dalvik virtual machine.

3. Finally, the Android Asset Packaging Tool (aapt) is used to combine .dex files with the AndroidManifest.xml
and other resources making up your application. It produces the .apk which is really just a zip file.

You can find .apk files on the Web and install them directly to your emulator or Android device although you
must be careful about installing un-trusted .apk files that could contain malicious code.

Using the Debugger
Review these pages on using the Android debugger:

e http://developer.android.com/tools/debugging/index.html
e http://developer.android.com/tools/debugging/ddms.html

Logging Messages

An alternative to the debugger for simple tracing is the Android logging class (android.util.Log) The log
class is used to send messages to the LogCat. The LogCat should be visible in one of the tabs near the bottom of
the Eclipse window. If you don’t see the LogCat, select Window > Show View > Other..., Android > LogCat to
make it visible.

To log messages, first import android.util.Log and declare a log tag (a unique identifier for your log
messages). Add a call to Log.v () in your program like so:
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package com.example.helloandroid;

import
import
import

android.app.Activity;
android.os.Bundle;
android.util.Llog;

public class MyFirstActivity extends Activity {

private static final String LOG_TAG = "HelloAndroid_tag";

/** Called when the activity is first created. */

@Override

public void onCreate(Bundle savedInstanceState) {
super.onCreate(savedInstanceState);
setContentView(R.layout.main);

int x = 2;
Log.v(LOG_TAG, "x is " + Xx);

Now run your program. When the onCreate () method runs, the Log.v () call will output “x is 2”to the

LogCat as shown below.

[:_ Problems | @ Javadoc @ Declaration | El Console | &3 LogCat 52 = Properties

Saved Filters

+

All messages (no filters)

Search for messages.

Accepts Java regexes. Prefix with pid:, app:, tag: or text: to limit scope.

=0

L.. Time PID Application Tag Text
D 10-22 19:55:4.. 297 EndroidRun... Shutting down VM
D 10-22 19:55:4.. 297 dalvikvm Debugger has detached; cbject registry had 1 entries
I 10-22 19:55:4.. 58 system process BctivityMa... Start proc com.example for activity com.example/.HelloAndroid?
I 10-22 19:55:4 297 Androidiun NOTE: attach of thread 'Bipder Thread 23' failed
[ 'v" 10-22 19:55:4.. 303 Com.example Hellofndro... x is 2
T TT—2Z 1975572, ST TETEN DroCe TCCIVILENE. - - UIoDIared GCLIVILY Com. cRamplc; .nellCANaroaietIvityy 1012 &
D 10-22 19:55:5.. 248 com.android.def... dalvilkvm GC_EXPLICIT freed 117 cbjects / 5112 bytes in 135ms

-

I

Note that there are different levels of log messages:

Verbose: Log.v ()
Debug: Log.d()
Information Log.1()
Warning Log.w()
Error Log.e ()

Typically, you’ll want to use the appropriate method to log the
severity of the error message.

Because the log messages can easily get lost in the numerous
messages shown in the LogCat, it’s a good idea to create a
filter so only the messages logged by our app are displayed.

[

&

Logcat Message Filter Settings

Filter logcat messages by the source's tag, pid or minimum log level,
Empty fields will match all messages.

Filter Name: Hello

by Log Tag: | HelloAndroid_tag
by Log Message:
by PID:

by Application Narme:

by Log Level:

Cancel

First click the green + next to Saved Filters (left side of the LogCat window). This will launch a dialog box as
shown to the right. Enter Hello for the Filter Name and HelloAndroid_tag as the Log Tag and press OK.

Now when “Hello” is selected from the list of filters, you should only be able to see the messages logged by the
app as shown below. If you'd like to see all the messages, click “All messages”.
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SavedFiters o = Bf Search for messages. Accepts Java reqexes. Prefix with pid;, app:, tag: or text: to limit scope.

All messages (no filters) (9€
Hello

L.. Time PID  Application Tag Text

Voo 10-22 20:05:12.575 358 COM. eXample HelloAndroid tag % is 2

Submission

Zip up your Eclipse project with the two Activities that communicate back and forth. Name it t1.zip. Submit your
program via Canvas.

Note on Grading (from the, Nathan former TA)

There are roughly 50 students in the class. Last semester, there were only about 30, and the grading on
even that few was taxing at times. If you turn in an app that doesn't even run on the emulator or device,
chances are | won't have time to look through your code and find out what was wrong. Test your app
before you turn it in on at least one other environment.

I've already said it, but make sure you test your apps. Last semester, | graded with a device with APl 15
and the emulator with API 10, so if it didn't work under one environment, | could check it under a
second. (You are to use minimum APl level of 14 and a target API level of 17) | found that most of the
issues last semester were not from different APls, but from people not testing their app thoroughly.
Since these apps are relatively simple to test (you're not programming an OS or writing an AVL tree that
can't really be understood by non-CS majors), you can have a friend or roommate play it once or twice
just to make sure.

Finally, the tutorials are relatively simple. However, you will occasionally run into some issues if you
change your environment (API version, computer you're using, etc). So start early and get them done
hassle-free.

Except as otherwise noted, the content of this document is
licensed under the Creative Commons Attribution 3.0 License
http://creativecommons.org/licenses/by/3.0

Frank McCown at Harding University, minor changes by Mike Scott
7


http://creativecommons.org/licenses/by/3.0

